Yahoo refuse tous les emails du site. Si vous avez une adresse chez un autre prestataire, c'est le moment de l'utiliser ;)

En cas de soucis, n'hésitez pas à aller faire un tour sur la page de contact en bas de page.

Topic "Utiliser un multiplexeur analogique CD4051B avec une carte Arduino / Genuino"

Flux RSS des posts récents dans ce topic ( Flux Atom)


Photo de profil de skywodd

skywodd

Membre

Membre du staff

#160 | Signaler ce message


Dans ce tutoriel, nous parlerons d'un petit circuit intégré bien pratique : le CD4051B, un multiplexeur analogique. Nous verrons à quoi sert ce circuit intégré et comment l'utiliser. Si vous avez déjà rêvé d'aligner des dizaines de potentiomètres ou de boutons sur un même panneau de contrôle, cet article est fait pour vous !

Lire la suite de l'article sur le site

Derniére modification le par skywodd


Pas de photo de profil

LaurentF

Membre

#161 | Signaler ce message


Voilà un article plus intéressant qui me permet d'apprendre des choses :)


#412 | Signaler ce message


Bonjour,

je trouve votre article très intéressant, détaillè et bien expliqué. toutes fois j’aimerais savoir si possible la différence entre l'ajout d'un multiplexeur ou un décodeur à l’Arduino. J'ai lu quelques part qu'en pouvait augmenter le nombre d'entrées d'une carte Arduino avec un décodeur mais les pins peuvent être utilisé juste en temps qu'entrés et pas en sorties. Ma question est pourquoi c'est le cas alors que le multiplexeur en peut l'utiliser comme entrée ?

Je vous remercie.


Photo de profil de skywodd

skywodd

Membre

Membre du staff

#418 | Signaler ce message


Je ne suis pas sûr d'avoir compris la question …

Ma question est pourquoi c'est le cas alors que le multiplexeur en peut l'utiliser comme entrée ?

par escale_atomique

Le multiplexeur analogique de l'article est bidirectionnel. Il marche aussi bien en entrée qu'en sortie, avec des signaux analogiques ou logiques.

Un multiplexeur numérique est généralement unidirectionnel. Il ne marche qu'en entrée ou en sortie, suivant le modèle. Ce type de circuit ne fonctionne qu'avec des signaux logiques.

Il existe aussi des registres à décalage ("shift register") qui fonctionnent uniquement en entrée ou en sortie suivant le modèle (exemple : CD4021 entrée, 74HC595 sortie).

Il existe aussi des modules d'extension ("gpio expander") qui permettent d'avoir des entrées / sorties indépendantes (configuration par logiciel), mais c'est un tout autre type de circuit.


Pas de photo de profil

arn

Membre

#973 | Signaler ce message


Bonjour, Tuto très intéressant.

Pensez vous que l'on peut traité un signal analogique audio avec ce type de montage ou avec un multiplexeur? Je veux dire commander numériquement (par un programme) le résistance des potentiomètre de voies analogiques alternatifs type signal audio…


Pas de photo de profil

Dana_Guen

Membre

#976 | Signaler ce message


Bonjour et merci pour ce tuto bien détaillé…que je me suis efforcée de suivre à la lettre mais qui n'a pas abouti au résultat escompté malheureusement. Matériel utilisé:

-arduino uno

-multiplexeur 8 voies (https://www.amazon.fr/Ils-74HC4051-multiplexeur-analogique-CJMCU-4051/dp/B07F3T3B61/ref=sr_1_13?ie=UTF8&qid=1542714760&sr=8-13&keywords=multiplexeur)

-2 potentiomètres 10k (testés d'abord sur les entrées analogiques A0 et A1) J'ai modifié le code pour n'afficher que les entrées 0,1 et 2 du multiplexeur (j'ai connecté cette dernière à la masse pour vérifier si la valeur affichée s'aligne à 0) toutes les 0,5 secondes.

Ci-joint en images mon montage et ce que j'obtiens dans le moniteur série;

https://imgur.com/guzNVkT

https://imgur.com/dboHWwl

https://imgur.com/zNY4r0m

https://imgur.com/s4HT7kV

-les pins VEE et GND sont bien connectées à la masse

-VCC est connectée aux 5V

-la sortie Z est connectée à l'entrée A0 (jumper wire rouge)

-la pin ENABLE est connectée à l'entrée digitale 2 (jumper wire vert)

-S0, S1 et S2 sont respectivement connectées aux entrées 3, 4 et 5 de l'arduino (jumper wires jaunes)

Les valeurs du moniteur sont…complètement indépendantes et de toute évidence erronées :'D

J'ai beau reprendre tout depuis le début en vérifiant chaque étape je ne vois pas ce qui m'échappe :/ J'ai vérifié au voltmètre que la pin E était bien à LOW, que la tension était bien à 5V sur VCC, 0V sur GND,(re)revérifié la tension aux bornes de mes potentiomètres. Bien que mon multiplexeur soit neuf, dans le doute je l'ai changé; même problème. Dans un élan de désespoir j'en suis venue à douter si il fallait ou non que je connecte des deux côtés les pins GND, VCC et VEE (qui sont en double sur ce modèle)…bref je dois avouer que je suis à court d'idées.

Toute aide est la bienvenue :)

Merci,

D.